Help support TMP


"Never Buy a Whirlpool Oven" Topic


4 Posts

All members in good standing are free to post here. Opinions expressed here are solely those of the posters, and have not been cleared with nor are they endorsed by The Miniatures Page.

For more information, see the TMP FAQ.


Back to the Technical Stuff Plus Board

Back to the Ranting Plus Board



339 hits since 5 Dec 2015
©1994-2017 Bill Armintrout
Comments or corrections?

Mako11 Inactive Member05 Dec 2015 9:03 p.m. PST

This oven has never worked right, and continuously fails to operate properly, since we got it when the house was built.

It's gas powered, 465 model, and works sometimes, but frequently not.

A lot of times it won't even light up, or runs for a while, and then shuts off. Usually ruining something we're in the middle of baking.

It's crazily unreliable.

Cooked a turkey partially for about 3.5 – 4 hours, and then just quit cycling to heat properly – just turned itself off, even though there was plenty of time left on the timer.

Now I haven't been able to get it to come back on to save my life, for the last four hours.

I suspect it is either a computer board issue, and/or the safety interrupt for the gas is somehow screwing up, to keep it from relighting.

The gas burners work fine.

Had a similar issue with another one in my house, previously, and replaced the sparking element in that one, and this one too.

I can't believe I should have to replace it again, already in this oven.

It's a total piece of crap.

JSchutt06 Dec 2015 6:45 a.m. PST

And I thought Whirlpool only made washing machines and dryers. I had to ditch my dryer for similar problems you are having with your oven. They probably contain the same parts….though I never tried to cook a turkey in my dryer.

RavenscraftCybernetics Inactive Member06 Dec 2015 9:45 a.m. PST

steam-dryer turkey is the best!

Mako11 Inactive Member06 Dec 2015 2:21 p.m. PST

Finished mine in the Weber, late last night, so wasn't a total loss, thankfully.

Oh, and the oven finally came on about 3:00 AM, when I tried it for the 100th time, about 12 hours later.

Sorry - only verified members can post on the forums.