Help support TMP


"Can't Access TravellerRPG.com/Coti" Topic


5 Posts

All members in good standing are free to post here. Opinions expressed here are solely those of the posters, and have not been cleared with nor are they endorsed by The Miniatures Page.

Remember that you can Stifle members so that you don't have to read their posts.

For more information, see the TMP FAQ.


Back to the SFRPG Message Board


Action Log

19 Jun 2020 3:15 a.m. PST
by Editor in Chief Bill

  • Changed title from "Seksmisja (aka Sexmission) (1984)" to "Can't Access TravellerRPG.com/Coti"Removed from Cold War (1946-1989) board
  • Changed starttime from
    18 Jun 2020 9:38 p.m. PST
    to
    18 Jun 2020 9:38 p.m. PSTRemoved from SF Media board

Areas of Interest

Science Fiction

Featured Hobby News Article


Featured Recent Link


Featured Ruleset


Featured Showcase Article

Blue Moon's Romanian Civilians, Part Five

The last four villagers from Blue Moon's Romanian set, as painted by PhilGreg Painters.


Featured Profile Article

Final Faction: Steadfast & Steel

Personal logo Editor in Chief Bill The Editor of TMP Fezian examines the remaining heroes in the first release.


Current Poll


Featured Movie Review


821 hits since 17 Jun 2020
©1994-2023 Bill Armintrout
Comments or corrections?

Thresher0118 Jun 2020 8:38 p.m. PST

I assume it is just me, and my computer, but for some reason I cannot access the TravellerRPG.com/Coti forum page.

Anyone else having issues with that.

My guess is it may have something to do with an anti-virus service I recently had on my PC, and perhaps they changed some of the settings, while removing a virus or three (ah, the irony of that on multiple levels – Traveller, Covid, and my computer!).

Any tips on how to fix it, without reversing and nuking the new safety/security protocols to keep viruses away from my computer?

Personal logo Saber6 Supporting Member of TMP Fezian19 Jun 2020 4:26 a.m. PST

link is up.

Change Browser?

MajorB19 Jun 2020 10:01 a.m. PST

That link works for me too.

Thresher0119 Jun 2020 10:02 a.m. PST

Thanks for the tip.

I've tried using IE and DuckDuckGo, but no luck, nor with Google either, even after adding in travellerrpg.com as a "redirect" on my PC with settings (got the hint to do that from some error messages popping up).

Still no joy.

Why do companies need to make life so difficult for us non-programmers?

LouisBaxter27 Jun 2022 12:13 a.m. PST

Yes, the problem may be because of the antivirus. The previous one used also used to block something from time to time

Sorry - only verified members can post on the forums.